You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

pom.xml 1.7KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. <?xml version="1.0" encoding="UTF-8"?>
  2. <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  3. <modelVersion>4.0.0</modelVersion>
  4. <groupId>com.ancient.addon.examples</groupId>
  5. <artifactId>Ancient-RPG-Example</artifactId>
  6. <version>1.0-SNAPSHOT</version>
  7. <packaging>jar</packaging>
  8. <repositories>
  9. <!-- Spigot -->
  10. <repository>
  11. <id>spigot-repo</id>
  12. <url>https://hub.spigotmc.org/nexus/content/repositories/snapshots/</url>
  13. </repository>
  14. </repositories>
  15. <dependencies>
  16. <!--Ancient API-->
  17. <dependency>
  18. <groupId>com.ancient</groupId>
  19. <artifactId>Ancient-RPG</artifactId>
  20. <version>1.0.0</version>
  21. </dependency>
  22. <!--Spigot API-->
  23. <dependency>
  24. <groupId>org.spigotmc</groupId>
  25. <artifactId>spigot-api</artifactId>
  26. <version>1.11.2-R0.1-SNAPSHOT</version>
  27. <scope>provided</scope>
  28. </dependency>
  29. <!--Bukkit API-->
  30. <dependency>
  31. <groupId>org.bukkit</groupId>
  32. <artifactId>bukkit</artifactId>
  33. <version>1.11.2-R0.1-SNAPSHOT</version>
  34. <scope>provided</scope>
  35. </dependency>
  36. </dependencies>
  37. <properties>
  38. <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
  39. <maven.compiler.source>1.8</maven.compiler.source>
  40. <maven.compiler.target>1.8</maven.compiler.target>
  41. </properties>
  42. </project>